PHP date()Functions
PHP Date/Time Reference Manual
Examples
Formats a local date and time, and returns the formatted date string:
<?php
date_default_timezone_set("PRC");
echo date("Y-m-d H:i:s") . PHP_EOL;
echo date("Y year m month d day H hour i minute s second") . PHP_EOL;
$time = strtotime("2018-01-18 08:08:08");
echo date("Y-m-d H:i:s", $time) . PHP_EOL;
?>
The output is as follows:
2018-01-31 22:09:35
2018 年 01 月 31 日 22 点 09 分 35 秒
2018-01-18 08:08:08
Definition and Usage
The date() function formats a local date and time, and returns the formatted date string.
Syntax
Returns a string produced according to the given format string using the integer timestamp. If no timestamp is given, the local current time is used. In other words, timestamp is optional and defaults to time().
| Parameter |
Description |
| format |
Required. Specifies the format of the output date string. The following characters can be used:
- d - Day of the month (from 01 to 31)
- D - A textual representation of the day of the week (three letters)
- j - Day of the month without leading zeros (1 to 31)
- l (lowercase 'L') - A full textual representation of the day of the week
- N - ISO-8601 numeric representation of the day of the week (1 for Monday, 7 for Sunday)
- S - English ordinal suffix for the day of the month (2 characters: st, nd, rd, or th. Used with j)
- w - Numeric representation of the day of the week (0 for Sunday, 6 for Saturday)
- z - The day of the year (from 0 to 365)
- W - ISO-8601 week number of the year (weeks start on Monday)
- F - A full textual representation of a month (January to December)
- m - Numeric representation of a month (from 01 to 12)
- M - A short textual representation of a month (three letters)
- n - Numeric representation of a month, without leading zeros (1 to 12)
- t - Number of days in the given month
- L - Whether it is a leap year (1 if it is a leap year, 0 otherwise)
- o - ISO-8601 year number
- Y - A four-digit representation of a year
- y - A two-digit representation of a year
- a - Lowercase Ante meridiem and Post meridiem: am or pm
- A - Uppercase Ante meridiem and Post meridiem: AM or PM
- B - Swatch Internet Time (000 to 999)
- g - 12-hour format, without leading zeros (1 to 12)
- G - 24-hour format, without leading zeros (0 to 23)
- h - 12-hour format, with leading zeros (01 to 12)
- H - 24-hour format, with leading zeros (00 to 23)
- i - Minutes, with leading zeros (00 to 59)
- s - Seconds, with leading zeros (00 to 59)
- u - Microseconds (new in PHP 5.2.2)
- e - Timezone identifier (e.g.: UTC, GMT, Atlantic/Azores)
- I (capital i) - Whether the date is in daylight saving time (1 if it is daylight saving time, 0 otherwise)
- O - Difference to Greenwich time (GMT) in hours (example: +0100)
- P - Difference to Greenwich time (GMT) in hours:minutes (new in PHP 5.1.3)
- T - Timezone abbreviation (examples: EST, MDT)
- Z - Timezone offset in seconds. The offset for timezones west of UTC is negative (-43200 to 50400)
- c - ISO-8601 date (e.g., 2013-05-05T16:34:42+00:00)
- r - RFC 2822 formatted date (e.g., Fri, 12 Apr 2013 12:01:05 +0200)
- U - Seconds since the Unix Epoch (January 1 1970 00:00:00 GMT)
The following predefined constants can also be used (available since PHP 5.1.0):
- DATE_ATOM - Atom (e.g., 2013-04-12T15:52:01+00:00)
- DATE_COOKIE - HTTP Cookies (e.g., Friday, 12-Apr-13 15:52:01 UTC)
- DATE_ISO8601 - ISO-8601 (e.g., 2013-04-12T15:52:01+0000)
- DATE_RFC822 - RFC 822 (e.g., Fri, 12 Apr 13 15:52:01 +0000)
- DATE_RFC850 - RFC 850 (e.g., Friday, 12-Apr-13 15:52:01 UTC)
- DATE_RFC1036 - RFC 1036 (e.g., Fri, 12 Apr 13 15:52:01 +0000)
- DATE_RFC1123 - RFC 1123 (e.g., Fri, 12 Apr 2013 15:52:01 +0000)
- DATE_RFC2822 - RFC 2822(Fri, 12 Apr 2013 15:52:01 +0000)
- DATE_RFC3339 - Same as DATE_ATOM (since PHP 5.1.3)
- DATE_RSS - RSS(Fri, 12 Aug 2013 15:52:01 +0000)
- DATE_W3C - World Wide Web Consortium (e.g., 2013-04-12T15:52:01+00:00)
|
| timestamp |
Optional. Specifies an integer Unix timestamp. The default is the current local time (time()). |
Technical Details
| Return value: |
Returns the formatted date string on success, or issues an E_WARNING error and returns FALSE on failure. |
| PHP version: |
4+ |
| Changelog: |
PHP 5.1.0: Added E_STRICT and E_NOTICE timezone errors. The valid range of timestamps is from Friday, December 13, 1901 20:45:54 GMT to Tuesday, January 19, 2038 03:14:07 GMT. Before 5.1.0, on some systems (e.g., Windows), timestamps were limited to 01-01-1970 to 19-01-2038. PHP 5.1.1: Added standard date/time format constants for the format parameter. |
PHP Date/Time Reference Manual Other extensions