Redis Config Set Command
The Redis Config Set command can dynamically adjust the configuration of the Redis server without requiring a restart.
You can use it to modify configuration parameters, or to change Redis's persistence mode.
Syntax
The basic syntax of the redis Config Set command is as follows:
redis 127.0.0.1:6379> CONFIG Set parameter value
Available Versions
>= 2.0.0
Return Value
Returns OK when the setting is successful, otherwise returns an error.
Example
redis 127.0.0.1:6379> CONFIG GET slowlog-max-len 1) "slowlog-max-len" 2) "1024" redis 127.0.0.1:6379> CONFIG SET slowlog-max-len 10086 OK redis 127.0.0.1:6379> CONFIG GET slowlog-max-len 1) "slowlog-max-len" 2) "10086"
Other Extensions